
Getting Started 

 

 

GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

12ENGINEERING SOFTW 

 

REBARCAD 
GETTING STARTED GUIDE 

 
 

RebarCAD 
Getting Started 

 

 



Getting Started 

 

 

2 Copyright © Computer and Design Services Limited 
GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

Contents 
 

Introduction ............................................................................................................... 3 

Compatibility ............................................................................................................. 4 

Drawing Sheets ......................................................................................................... 5 

Members ................................................................................................................. 14 

Navigating around the Bar list ................................................................................. 17 

Formatting the Bar list ............................................................................................. 21 

Printing Bar lists & Reports...................................................................................... 23 

Free-form Reports ................................................................................................... 26 

Orders ..................................................................................................................... 29 

Issuing & Revision ................................................................................................... 34 

 

 



Getting Started 

 

 

3      Copyright © Computer and Design Services Limited 
GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

Introduction 

This guide aims to help users to familiarize themselves with some of the new functionality in 
RebarCAD. It attempts to highlight significant new aspects of this product that may not be 
immediately apparent on running the software. The guide communicates the location of new 
commands and explains their purpose. Reading this guide will equip you with the knowledge 
needed to explore the new features in more detail.  
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Compatibility 

This section confirms some details about drawing compatibility.  

You can open drawings produced under any previous version of RebarCAD. 
 
 
RebarCAD includes a Save As V8.4 Drawing command that allows you to save a drawing to 
be compatible with any RebarCAD V8.4 based release. On running this command the 
following confirmation message will appear: 
 

 
 
Saving back to v8.4 comes with the loss of some specific data as listed in the dialog.  
 
You can not open RebarCAD drawings directly in an older version of RebarCAD unless you 
have previously used this Save As V8.4 Drawing command.  
 

 

Key Points 

▪ You can open any existing RebarCAD drawing under RebarCAD 

▪ You can save a drawing produced using RebarCAD to be compatible with RebarCAD 
v8.4 by using the Save As V8.4 Drawing command. Some specific data will be lost as 
part of this process. 

▪ You can not open RebarCAD drawings under an older version of RebarCAD unless you 
have used the Save As V8.4 Drawing command 

 

Commands 

Action      Menu       Toolbar 

Save drawing compatible with V8.4    RebarCAD > Utilities > Save As V8.4 Drawing  None  
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Drawing Sheets 

This section explains the new concept of drawing sheets, introduced in v9.0.  

Drawing sheets allow you to produce several drawings together with their associated bar lists 
from within a single AutoCAD DWG file. Whole structures can be detailed in one AutoCAD 
DWG file and split between several drawing sheets. Each drawing sheet and associated bar 
list can be issued and tracked independently.  

A drawing sheet can either be an AutoCAD layout or a specific area of model space. 
Reinforcement can be assigned to specific drawing sheets as you detail or at a later time.  

You can only produce a formatted report (e.g. combine bars) when you have created at least 
one drawing sheet. 

 

Creating drawing sheets 

There are a number of ways to create a drawing sheet. Users of CADS-VPM and CADS 
Scale can configure drawing sheets to be created automatically as part of the process of 
setting up a drawing. Other users can also ensure drawing sheets are created as part of their 
own drawing setup procedure. Instructions on configuring your own title blocks to both trigger 
drawing sheet creation and to map to the bar list headers and footers can be found later in 
this chapter. 

The creation of drawing sheets is triggered by the insertion of a title block that contains an 
attributed tag that describes the drawing number. If a value is entered for this attribute then a 
corresponding drawing sheet will be created inside RebarCAD. If no value is specified for this 
attribute then RebarCAD will present the following dialog to ask for the drawing sheet number.  

 

 

 

The drawing sheet number can be changed by editing the associated drawing number 
attribute with the title block. Drawing sheets can be deleted by erasing the corresponding title 
block. So essentially, you can think of a drawing sheet as an instance of a title block within 
the drawing. If you decide not to insert a title block then bars will be assigned to an 
UNASSIGNED drawing sheet. You can assign them to a valid drawing sheet later by using 

the Assign Bar to Drawing Sheet  command, as described later. 
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The drawing sheets are listed in the bar list as follows; 

 

 

 

If you select one of these drawing sheets then the only bars that belong to that specific 
drawing sheet will be shown in the formatted and free-form view. 

 

Configuring your title blocks 

You can configure your own title blocks to work with RebarCAD by selecting the Configure 
Title Block command. This feature will be shown when you first run RebarCAD following 
installation and when the program detects that a title block may have been inserted. 

This Configure Title Block feature allows you to select your own title block and then map its 
attributes to RebarCAD’s data fields. In order to create drawing sheets and therefore 
formatted reports you will need to ensure that the drawing number field is mapped to an 
appropriate attribute within your title block. Mapping the remaining RebarCAD data fields to 
title block attributes will result in the bar list headers and footers being automatically 
populated from the title block. 

If your title block has no attributes then the Configure Title Block command will offer you the 
chance to automatically add a single attribute to represent the drawing number. 

The Configure Title Block dialog is shown below: 
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Please consult the RebarCAD Customization & Configuration Guide for more information 
on saving the title block settings for future drawing sessions. 

You can configure RebarCAD to work with any number of title blocks regardless of whether 
they use consistent attribute naming. You can use the same method to migrate any title 
blocks that are imbedded in an AutoCAD DWT file. 



Getting Started 

 

 

8      Copyright © Computer and Design Services Limited 
GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

Assigning bars to drawing sheets 

When you attempt to draw a bar then you will see that a new field that controls the drawing 
sheet assignment of the bar is present on the Bar Drawing dialogue. As shown below. 

 

 

 

The program will default to the last drawing sheet created. You can change this default setting 

by using the Set Current Drawing Sheet  command, as shown below: 
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You can use the standard RebarCAD bar/label editing commands to change a bar’s drawing 

sheet assignment or alternatively use the new Assign Bar to Drawing Sheet  command 
that’s available from the RebarCAD->Editing menu. This command allows for the rapid 
assignment of multiple bars, as shown below: 
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The following tutorials help explain some of the basic operations related to drawing sheets. 

 

 

Try it: Create a drawing sheet using CADS-VPM 

1 Launch RebarCAD 

2 Click CADS-VPM->Create Layout  command 

3 Accept the default layout name and sheet. Click create 

4 Immediately click OK on the Edit Attribute dialog 

5 Specify a drawing sheet number of “Sheet 1” in the RebarCAD Drawing Sheet Number 
dialog <Note: this dialog will not appear if you specify a value for Drawing Number, in the 
edit attributes dialog> 

6 Click RebarCAD->View Bar List  command 

7 You should see that a drawing sheet called “Sheet1” has been created. If you now 
attempt to draw a bar using RebarCAD->Draw Bar->New Mark then you will see that this 
now defaults to this new drawing sheet. If you draw a bar then this bar will be assigned to 
this new drawing sheet 

 

 

 



Getting Started 

 

 

11      Copyright © Computer and Design Services Limited 
GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

Try it: Create a paper space drawing sheet using CADS Scale 

1 Launch RebarCAD 

2 Click CADS Scale->Drawing Setup  command 

3 Ensure “Apply setup to” is set to “Layout1”. Select “Standard A0 setup”. Click OK 

4 Click Modify on the “Page Setup Manage” dialog and select A0 paper size. Click close 

5 Select a scale of 1:50 in the “Setup Scale” dialog. Click OK 

6 Immediately click OK on the Edit Attribute dialog 

7 Specify a drawing sheet number of “Sheet 1” in the RebarCAD Drawing Sheet Number 
dialog. <Note: this dialog will not appear if you specify a value for Drawing Number, in the 
edit attributes dialog > 

8 Click RebarCAD->View Bar list  command 

9 You should see that a drawing sheet called “Sheet1” has been created. If you now 
attempt to draw a bar using RebarCAD->Draw Bar->New Mark then you will see that this 
now defaults to this new drawing sheet. If you draw a bar then this bar will be assigned to 
the drawing sheet titled “Sheet 1” 

 

 

Try it: Create a model space drawing sheet using CADS Scale 

1 Launch RebarCAD 

2 Click CADS Scale->Drawing Setup  command 

3 Ensure “Apply setup to” is set to “Model”. Select “Standard A0 setup”. Click OK 

4 Select a scale of 1:50 in the “Setup Scale” dialog. Click OK 

5 Immediately click OK on the Edit Attribute dialog  

6 Specify a drawing sheet number of “Sheet 1” in the RebarCAD Drawing Sheet Number 
dialog. <Note: this dialog will not appear if you specify a value for Drawing Number, in the 
edit attributes dialog > 

7 Click RebarCAD->View Bar list  command 

8 You should see that a drawing sheet called “Sheet1” has been created. If you now 
attempt to draw a bar using RebarCAD->Draw Bar->New Mark then you will see that this 
now defaults to this new drawing sheet. If you draw a bar then this bar will be assigned to 
the drawing sheet titled “Sheet 1” 
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Try it: Create a paper space drawing sheet using AutoCAD 

1 Launch RebarCAD 

2 Make “Layout1” active by selecting the tab 

3 Right click on the Layout1 and select “Page Setup Manager…”, Select Modify, Select a 
A0 paper size, Click Ok and Close. 

4 Select Insert->Block or type “Insert”  

5 Browse to the “\cads\AutoCAD XXXX\CADS Viewport Manager\blocks folder” and select 
A0CADS.dwg. Click Ok and place the title block 

6 Double click on the title block 

7 Specify a drawing sheet number of “Sheet 1” in the RebarCAD Drawing Sheet Number 
dialog 

8 Click Ok on the attribute edit dialog 

9 Click RebarCAD->View Bar list   command 

10 You should see that a drawing sheet called “Sheet1” has been created. If you now 
attempt to draw a bar using RebarCAD->Draw Bar->New Mark then you will see that this 
now defaults to this new drawing sheet. If you draw a bar then this bar will be assigned to 
the drawing sheet titled “Sheet 1” 

 

 

Try it: Configuring your title block to work with RebarCAD 

1 Launch RebarCAD 

2 Insert an instance of your title block using AutoCAD  

3 Click RebarCAD->Configuration->Configure Title Block command 

4 Use the pick button to select your title block 

5 Specify which attributes relate to which RebarCAD data fields. Ensure you map an 
attribute to the first drawing number field  

6 Click Apply 

7 You will now be prompted to specify the drawing sheet number for the previously inserted 
title block. All subsequent inserts of this title block will result in the creation of a 
RebarCAD drawing sheet. You can confirm drawing sheet creation by viewing the bar list  

 

Key Points 

▪ Drawing sheets are created when valid title blocks are inserted 

▪ You can configure your title blocks to work with RebarCAD by using the Configure Title 
Block command.  

▪ You can use the Configure Title Block command to automatically add a drawing number 
attribute to title blocks that have no attributes 

▪ Drawing sheets can be edited or deleted via the associated title block 
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▪ You can only produce a formatted view (i.e. combined bars) when you have at least one 
drawing sheet 

▪ You can set the default drawing sheet by using the Set Current Drawing Sheet 
command 

▪ You can assign bars to a drawing sheet as you draw them or at a later time 

▪ Use the new Assign bars to Drawing Sheet  command when doing multiple 
assignments  

▪ The program may sometimes mistakenly guess that an inserted block is a title block and 
show the Configure Title Block dialog. In these inappropriate situation simply select the 
cancel button 

 

 

Commands 

Action    Menu        Toolbar 

Create layout   CADS-VPM > Create Layout    CADS-VPM   

 

Drawing setup   CADS Scale > Drawing Setup…    CADS-Scale  

 

View bar list    RebarCAD > View Bar list…    RebarCAD     

  

Assign bars to drawing sheet RebarCAD > Editing > Assign bars to Drawing Sheet... Editing           

 

Set Current drawing sheet  RebarCAD > Draw Bar > Set Current Drawing Sheet… Draw Bar       

  

Configure title block  RebarCAD > Configuration > Configure Title Block Configuration 
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Members 

The new concept of members has been introduced in v9. Members can be used 
as a way of grouping and categorizing bars.  
 
The Release quantity is no longer present in RebarCAD. If you wish to produce a 
duplicate of a specific detail without detailing it then you will need to use the 
Member quantity option. You can very easily use Members to build up Releases. 
This will be described in the Releases section of this guide.  
 

The new Members  dialog is shown below. 
 

 
 
To make the draw bar dialog default to a specific member you can simply 
highlight the required member within the list and click the “Make Current” button. 
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You can assign existing bars to a member by using the Assign Bars to Member 

 command, as shown below. 
 
 

 
 
Use the selection buttons to build up a list of bars to be assigned to a member, 
select the required member from the list, then click apply. 
 
The bars are assigned to the member on selecting apply and the number of 
selected bars is reset to 0 which allows you to make additional assignments. You 
can select the “…” button to access the Members dialog in order to create new 
members. 
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You can see a list of members together with their weight information from inside 
the bar list by selecting the Members Mode, as shown below. A fuller description 
of this can be found in the section titled “Navigating the Bar list”  
 
 

 
 

 

 

Key Points 

▪ Members quantity options in v9 has replaced the Releases quantity option in v8 

▪ You can use Members to quickly build up Releases 

▪ To make the bar draw dialog default to a specific member set it as current 

▪ Use the Assign Bars to Members  command to assign existing bars to a member 

▪ You can view information about members from inside the bar list 

 

 

Commands 

Action    Menu       Toolbar 

Define Members   RebarCAD > Draw Bar > Set Members  Draw Bar    

 

Assign bars to member  RebarCAD > Editing > Assign Bars to Members Editing        

 

View bar list    RebarCAD > View Bar list…   RebarCAD 
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Navigating around the Bar list 

The bar list dialog and ordering related functionality has been completely 
redesigned to offer improved usability, clarity and configurability. This section 
explains how to navigate around the new bar list dialog. 
There are three main areas to the bar list dialog as shown below. 
 

▪ The Navigation area: This area contains a tree view of either the drawing 
sheets, members or releases. 

 
▪ The Data area: This displays the bar bending data depending on the 

selection chosen in the navigation area. This area has two tabs, 
formatted and free-form. These tabs will be described later. 

 
▪ The Mode area: This area contains three buttons that alters whether the 

navigation area, and therefore the data area, displays data pertaining to 
drawing sheets, members or releases. 
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By default, the Navigation area will show a list of all the currently created drawing sheets. 
Selecting a drawing sheet will filter the Data area to show just bars that are assigned to that 
drawing sheet. 

 

 

Selecting the Members button from the Mode Area, as shown below, will toggle the 
Navigation area to show information about members. Selecting a member will filter the Data 
area to show just bars belonging to the selected member. 

 

 

 

 

 

Selecting the Release button from the Mode Area will toggle the Navigation area to show 
information about releases. Further information on releases can be found later in this guide. 
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Formatted versus Free-form 

For a given drawing sheet you can choose to view the bar bending data in the Data area in 
either a formatted or free-form style. You can toggle between these styles by selecting the 
corresponding tab above the Data area, as shown below. 

 

 

 

When the Mode area is set to Member or Release you will notice that the formatted tab is 
unavailable, this is because you can only view formatted data from the drawing sheet mode.  

The formatted style will display the bar bending data as it will appear on the printed (or bar 
list on drawing) report. In the formatted mode you can sort, combine and segregate the bars 
bending data, as well as attach diagrams. You can manually insert text lines, page breaks 
and even move lines about to produce the required formatted bar list. 

The free-form style will display the raw unformatted bar bending data so you can produce 
reports beyond the constraints of any company or industry standard. You can filter, group and 
order the bar bending data as required. A full description of this feature can be found in the 
section titled “Free Form Reports”. 

 

 

Try it: Navigating around the bar list  

1 Launch RebarCAD 

2 Create three drawing sheets called “Sheet 1”, “Sheet 2” & “Sheet 3”  

3 Create three members called “Member 1”, “Member 2” & “Member 3”  

4 Draw numerous bars and assign them to the various drawing sheets and members 

5 Click View Bar list  command  

6 By default the formatted view of the first drawing sheet (“Sheet 1”) should be displayed 

7 Select each drawing sheet in turn to filter the Data view to show just bars belonging to 
that drawing sheet  

8 Select the Member button from the Mode Area to change the mode of the Navigation 
area. The Navigation area should now show the list of members 

9 Select each member in turn to filter the Data view to show just bars belonging to that 
drawing sheet 

10 Select the Drawing Sheet button from the Mode Area to change the mode of the 
Navigation area. The Navigation areas should now show the list of drawing sheets 

11 Select the formatted tab to toggle the style of the Data area 
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Key Points 

▪ The Navigation area can be toggled to show drawing sheets, members or releases by 
using mode selector 

▪ You can only view a formatted view from the drawing sheet mode 

▪ The Data area is filtered depending on the selected drawing sheet, member or release 

▪ The free-form style can be used to produce quick queries and reports 

 

 

Commands 

Action    Menu        Toolbar 

View bar list    RebarCAD > View Bar list…    RebarCAD 
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Formatting the Bar list 

It is now much easier to format the bar list to achieve your required layout. The 

following Format Bar list  dialog is available from the Bar list->Edit menu. 
 

The Format Bar list  command is only available for the formatted view which 
is in-turn only available when working with drawing sheets.  
 

 
 
You can apply three levels of sorting, the first having an additional segregated 
option. Additionally you can specify whether you’d like diagrams attached. The 
entire bar list can also be combined. 
 
The “Reset defaults” button can be used to restore the default settings from the 
currently configured bar list configuration file. 
 
You are also free to manipulate the bar list manually using a range of commands.  
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Or by directly selecting a line within the bar list and using a right mouse click to 
show available options. 
 

 
 
 
The Bar List on Drawing by default will produce a simple unformatted report. i.e. 
any manual formatting will not be reflected. You can configure the Bar List on 
Drawing to shown all manual formatting as follows: RebarCAD->View Bar List-
>Settings->Configure->Bar List tab->Change Bar List Table on Drawing 
Template from Bent Bar List by Release to Bar List with Header.    
 
By default the bar list will be automatically combined on events such as placing a 
bar list on drawing. You can configure the bar list to combined either always, only 
during specific actions, or wholly via the manual commands. More details on 
these configuration options can be found in the RebarCAD Customization & 
Configuration Guide 
 

 

 

Key Points 

▪ The formatting options can only be applied to the formatted view and not to the free-form 
view. So you will need to have at least one drawing sheet created 

▪ Select a bar in the bar list and use a right mouse click to find available options 

▪ Some manual manipulation of the bar list may result in a confliction with the automatic 
formatting options. This will result in the automatic formatting options being reset 

▪ You can configure exactly when the program should combine bars 

 

Commands 

Action    Menu        Toolbar 

View bar list    RebarCAD > View Bar list…    RebarCAD 
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Printing Bar lists & Reports 

A formatted view of the bar list can be printed using the typical Print  and Print 

Preview options from the Bar list->File menu. You will first need to ensure that 
the correct drawing sheet is selected from the Navigation area and that the bar 
list has been formatted as required. 
 

 
 
The Print Preview option offers some additional export options. To access these 
select either the “Export/Save To” options from the File menu or the following 
toolbar icons. 
 

 
 

 
 

The style of the printed reports is controlled by the report templates which can be 

configured from the Configure Settings  command from the Bar list->Settings 
command. A detailed description of how to customize your reports can be found 
in the RebarCAD Customization & Configuration Guide. 
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Alternatively you can place a bar list on the drawing. This can be done from 

AutoCAD by selecting the Place Bar list on Drawing  command from the 
RebarCAD->Place Bar list menu.  
 
The product is configured to place a Bar List on Drawing by Release. So on 
selecting this command you will be asked to select the required release.  
 
You can configure the product to place a Bar List on Drawing by Drawing Sheet 
as follows:  
RebarCAD->View Bar List->Settings->Configure->Bar List tab. 

▪ Change the Display Bar List by option from Release to Drawing Sheet 
▪ Change the Bar List Table on Drawing Template option from Bent Bar 

List by Release to Bar List by Drawing Sheet 
 

On placing a Bar List on Drawing you will be asked to specify the height of the 
bar list. This option allows you to split the Bar List on Drawing to fit around 
details. 
 
If changes are made to bars following the placement of the bar list on drawing 
then an “INVALID” message will appear over the bar list on drawing, as shown 
below: 
 

 
This is to signify that the bar list is now out-of-date. The bar list on drawing can be 

updated at any time by selecting the Refresh Bar list on Drawing  command.    

 

 

Try it: Printing a bar list  

1 Launch RebarCAD 

2 Create a drawing sheet using one of the methods described in the Drawing Sheet section 
above 

3 Draw some bars on this new drawing sheet 

4 Click View Bar list  command  

5 Click Print Preview from the File menu 

 

 

Try it: Place and updating a bar list on drawing  

1 Launch RebarCAD 



Getting Started 

 

 

25      Copyright © Computer and Design Services Limited 
GLOBAL CONSTRUCTION 
SOFTWARE AND SERVICES 

2 Create a drawing sheet using one of the methods described in the Drawing Sheet section 
above 

3 Draw some bars on this new drawing sheet 

4 Click Place Bar list on Drawing  command  

5 Tick the drawing sheet and click Ok 

6 Place the bar list on drawing 

7 Edit the bar size of one of the bars 

8 The bar list on drawing should now show be shown as “INVALID” 

9 Click Refresh Bar list on Drawing  command 

10 The bar list on drawing should now be up-to-date 

 

 

Key Points 

▪ Ensure you have the correct drawing sheet selected before doing a print 

▪ You can configure the bar list on drawing to be by Release or by Drawing Sheet 

▪ The preview dialog includes some additional export options. (e.g. PDF, Excel) 

▪ The bar list on drawing will display an “INVALID” message if subsequent edits are made 
to the bars being shown. The bar list can be refreshed by using the Refresh Bar list on 

Drawing  command. 

 

 

Commands 

Action    Menu        Toolbar 

View bar list    RebarCAD > View Bar list…            RebarCAD      

 

Place bar list on drawing       Place Bar list > Place Bar list on Drawing                Place Bar list   

   

Refresh bar list on drawing    Place Bar list > Refresh Bar list on Drawing             Place Bar list   
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Free-form Reports 

A custom report can be produced from the bar bending data using the free-form 
view. To access this open the bar list and select the free-form tab as shown 
below: 
 

 
 
The bar bending data will initially be displayed in the order in which the bars were 
created. You can change the order of the bar bending data by selecting the 
required column header. The order can be changed from ascending to 
descending by repeatedly clicking on the column header.  
 

 
 
You can group bars with the same property by right clicking on the column 
header and selecting the Group by This Column option, as shown below. You 
can group several columns if required. These can be ungrouped by selecting the 
Ungroup option. 
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You can add/remove columns by right clicking on a column header and selecting 
the Column Chooser option. This will display a list of available columns. These 
can be dragged to the column header area as required. You can also drag 
unwanted headers from the column header area into this dialog. 
 
 

 
 
Once you have the required report you can select the Print or Print Preview 
command from the Bar list->File menu. 
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The example report below shows a report of just the type A615/40, size #5 bars.  
 

 
 

 

Try it: Creating a free form report  

1 Launch RebarCAD 

2 Draw numerous bars of a variety of sizes and types 

3 Click View Bar list  command  

4 As we have no drawing sheets then it will be in free-form mode 

5 Right click on the Type column header and select Group by this Column 

6 Right click on the Bar Size column header and select Group by this Column 

7 Expand some of the groupings by selecting the  symbol 

8 Click Print Preview  

 

 

Key Points 

▪ Select the Free-form tab to switch to free-form mode  

▪ Right click on the column headers to see available options 

▪ The free-form view does not show combined bars 

 

 

Commands 

Action    Menu        Toolbar 

View bar list    RebarCAD > View Bar list…    RebarCAD 
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Orders 

The appearance and usability of the dialogs relating to releases have been 
improved. 
 

The new Releases  dialog is shown below: 
 

 
 

To make the draw bar dialog default to a specific release you can simply highlight 
the required release within the list and click the “Make Current” button. 
 
You can assign existing bars to a release by using the Assign Bars to Release 

 commands, as shown below: 
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Use the selection buttons to build up a list of bars to be assigned to a release, 
select the required release from the list then click apply. You can use the 
additional filter options to help build up the required selection of bars.  
 
You can also build up your bar selection directly from members or drawing 
sheets, as shown below: 
 

 
 
 
The bars are assigned to the release on selecting apply and the number of 
selected bars is reset to 0 which allows you to make additional assignments. You 
can select the “…” button to access the releases dialog to create or modify the 
releases. 
 
You can review the status and weight of the releases from the bar list by selecting 
the Release options from the Mode area of the bar list, as shown below: 
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Selecting a release will filter the Data Area to show just bars belonging to the 
selected release. 
 
Once you have specified your required release you can now order these from the 
Bar List. Select the Order Material command from the Production menu. This will 
display the following dialog. 
 

 
Select which release you wish to order and specify the required location for the 
production output file. You will need to specify a UON. This UON will be used to 
build up the default name of the production output file. 
 
Use the configure button to select the required production system, as shown 
below: 
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Additional dialogs may appear that request additional data for specific production 
systems. 
 

 

Try it: Order a bar  

1 Launch RebarCAD 

2 Click Draw Bar New Mark 

3 In the Releases dialog create a release called “001”.  

4 Make this current by selecting the “Make Current” button 

5 Draw a bar of any shape/size 

6 Click View Bar list  command  

7 Click Order Materials from the Production menu 

8 Tick release “001”, specify a path, enter a UON, then click Ok 

9 Depending on which production system you have configured you may be asked to specify 
additional data  

10 Use Windows Explorer to confirm the creation of the appropriate file 
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Key Points 

▪ You build up releases very quickly from members and drawing sheets  

▪ All ordered bars will be locked from future editing. Use un-order if required 

▪ The draw bar dialog defaults to the release that is set to current in the release dialog 

 

 

Commands 

Action    Menu        Toolbar 

View bar list    RebarCAD > View Bar list…    RebarCAD 

 

Define release   RebarCAD > Draw Bar > Set Release …   Draw Bar    

 

Assign bars to release  RebarCAD > Editing > Assign Bars to Release  Editing        
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Issuing & Revision 

RebarCAD includes a sophisticated issuing and revision system. Once the 
drawing and bar list have been completed you can issue them together. 
Subsequent edits to bars will be marked within the drawing and bar list. 
 
To issue a drawing sheet together with the bar list select the Issue Drawing 

Sheet  command from the RebarCAD->Review menu. 
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Following the issues a revision table will be automatically generated. If the title block does not 
contain this table then you will be asked to place the table manually. 

 

 

 

If you now edit any of the bars within the issued drawing sheet then they will automatically be 
marked with a revision cloud and symbol, as shown below: 

 

 

 

The bars list includes a Revision Mark column (last column) that identifies which revision a 
bar belongs to, as shown below: 

 

A track changes layer is also created automatically as part of the revision. This can be used 
to identify and control revision change. The layer name is prefixed with the drawing sheet 
number and includes the corresponding revision letter (e.g. Sheet1Revision1Changes). 
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Try it: How to issue, revision and re-issue a drawing sheet together with bar list  

1 Launch RebarCAD 

2 Create a drawing sheet using one of the methods described in the Drawing Sheet section 
above 

3 Draw some bars on this new drawing sheet 

4 Click the Issue Drawing Sheet  command  

5 Accept all the defaults in the Issue Drawing Sheet dialog by pressing Ok  

6 If the drawing sheet was created in paper space then you should now be in the 
associated layout. Depending on which title block you inserted you will either see a 
revision table automatically appended to the title block or be asked to place one manually 

7 Edit the size of one of the issued bars. Click Ok when the RebarCAD revision warning 
appears  

8 A revision cloud should now appear around the edited bar label 

9 Click View Bar list  command to see that a revision 1 letter has been applied to the 
edited bar  

10 Using AutoCAD locate the AutoCAD layer that is suffixed with drawing sheet name. (e.g. 
Sheet1Revision1Changes) Toggle this layer on/off to show/hide the revision clouds and 
annotation 

11 We have now completed our revisions so now need to re-issue the drawing using the 

Issue Drawing Sheet  command 

12 Accept all the defaults in the Issue Drawing Sheet dialog by pressing Ok. Note that the 
Revision Mark field now shows 1 

13 The revision table will now have a Revision 1 entry 

 

 

Key Points 

▪ You can issue a bar list with or without its associated drawing sheet  

▪ Revision clouds, annotation and track change layers are generated automatically 
following the edit of any bar that belongs to an issued drawing sheet 

 

Commands 

Action    Menu       Toolbar 

View bar list    RebarCAD > View Bar list…   RebarCAD 

 

Issue drawing sheet  RebarCAD > Review > Issue Drawing Sheet… Review       

 

   


